2 Replies Latest reply: Jan 12, 2011 2:02 PM by turtletsg RSS

Excludes and scan tags ignored in Maven plugin

turtletsg Newbie

I've been configuring the Maven plugin to report only certain items. The "reports" tag in configuration works great, limiting the reports I see. So do "source" and "destination." However, whenever I use the "scan" or "excludes" tags, it completely ignores what I write. This is so true that I can put "<exclude>*</exclude>" or "<exclude>*.jar</exclude>" and the report will be untouched, still reporting all of the jars.

 

This is my code:

 

<configuration>

                    <reports>

                        <report>multiplejars</report>

                    </reports>

                    <excludes>

                        <exclude>*.jar</exclude>

                    </excludes>

                    <scan>.class</scan>

                    <!-- This is the location which will be scanned for generating tattletale reports

                    -->

                    <source>C:\sourcedir</source>

                    <!-- This is where the reports will be generated -->

                    <destination>C:\destdir</destination>

</configuration>

 

My goal is to have only the multiple jars report, where it scans to see if class files are located in multiple jars on the classpath. Unfortunately, I hav other jars that I want to skip the scanning of because I already know they will be duplicate and I don't care about them.

 

I've also tried setting the property in the .properties files, but that seems to be overwritten whenever I recompiled the code. I'm using version 1.1.1.Final.

 

Please let me know if this is a bug or where I should set these simple properties so they will actually be paid attention to when the reports are generated. Thanks!

  • 1. Excludes and scan tags ignored in Maven plugin
    Jesper Pedersen Master

    Only scanning .jar like files are supported atm. Let me know if you want to work on .class support.

  • 2. Excludes and scan tags ignored in Maven plugin
    turtletsg Newbie

    Update: I have a fix to the exclusion issue: apparently "*" is not supported, so to exclude any jar, for example one ending in "example", like "this-example.jar", one would write:

     

    <configuration>

       <excludes>

           <exclude>example.jar</exclude>

       </excludes>

    </configuration>

     

    This is a bit counter-intuitive, but works.

     

    Jesper- I would not have time to fix this at this point in time, but I do think it would be helpful to note that only JAR scanning is available at this time for future developers not to make the same assumption I did in the user manual or other such page.

     

    Thanks.