2 Replies Latest reply: Aug 26, 2010 2:01 AM by R Saravana Prasad RSS

upgrade to JBoss-5.1.0.GA

R Saravana Prasad Newbie

What are the steps to follow

in upgrading a jboss-seam-2.0.0CR1 application
from JBoss-4.2.2 to Jboss-5.1.0.GA

 

Thanks

  • 1. Re: upgrade to JBoss-5.1.0.GA
    Wolfgang Knauf Master

    There is no upgrade guide available. It is try and error: deploy the app to 5.1 and see what happens ;-)

     

    I bet there will be XML parsing errors, because 5.x became more strict on validating xml config files. But hopefully you used an IDE with xml validation when creating your app, because this will avoid those problems ;-.).

     

    Best regards

     

    Wolfgang

  • 2. Re: upgrade to JBoss-5.1.0.GA
    R Saravana Prasad Newbie

    Thanks. Seam application using jboss-seam-2.0.0.CR1 jars on jboss-4.2.2 could be upgraded successfully to jboss-5.1.0.GA

    using jboss-seam-2.2.0.GA jars. Richfaces jars that come with jboss-seam-2.2.0.GA supports User Interface and no seperate download of richfaces was required. "seam2migration.txt" inside jboss-seam-2.2.0.GA will be of help.

     

    LDAP authentication through our portal page for the seam application in components.xml required a change

    From:

    <core:init debug="@debug@" jndi-pattern="@jndiPattern@"/>

     

    To:

    <core:init jndi-pattern="@jndiPattern@" debug="@debug@" security-enabled="false" />

     

    Thanks again

     

    Saravana Prasad