7 Replies Latest reply: Nov 20, 2006 8:35 AM by Aron Gombas RSS

    Basic installation help

    Ian Brown Newbie

      I'm evaluating using kosmos and cruise control at the moment. I'm new to the world of application and portal servers, so please bear with me if I'm doing something stupid.

      To keep the process as simple as possible, I have installed all of the release components out of the box. I am running on WinXP with Java JDK 1.5.0_09

      From jboss I have downloaded the file jboss-portal-2.4.0-bundled.zip and unzipped it into the c:\jboss directory. This zip contains both the server and the portal server.

      Next, I have downloaded kosmos-0.2.0RC2-for-jboss-portal.zip and unzipped that to c:\jboss too.

      Now, I copy the 3 war directories (kosmos-portlet.war, kosmos-server.war and slide.war) from C:\jboss\kosmos-0.2.0RC2-for-jboss-portal\deploy into C:\jboss\jboss-portal-2.4.0\server\default\deploy

      Then (with JDK_HOME set correctly), I open a command prompt, change directory to C:\jboss\jboss-portal-2.4.0\bin and then invoke the run batch file.

      After a minute or so, the output tells me that the server is installed and so I open the page http://localhost:8080/portal and sure enough it is there with a kosmos tab. When I go to the kosmos tab, however, not all is well in the world.
      Each of the portal windows (if that is the correct terminology) has the heading 'cannot render' and then an Object not found message in the body. Is this to be expected? It looks like something has gone wrong. A quick cut and paste from the internet explorer page gives the following text:

      Cannot render
      Object not found KosmosDependenciesSfMonitoringPortletInstance

      Cannot render
      Object not found KosmosToolsSfMonitoringPortletInstance

      Cannot render
      Object not found JBossProductsSfMonitoringPortletInstance

      Cannot render
      Object not found JBossSvnMonitoringPortletInstance

      Cannot render
      Object not found GmfCcMonitoringPortletInstance

      Cannot render
      Object not found JBossCcMonitoringPortletInstance

      Cannot render
      Object not found AtlassianJiraMonitoringPortletInstance

      Cannot render
      Object not found CodehausJiraMonitoringPortletInstance

      Cannot render
      Object not found JBossJiraMonitoringPortletInstance

      Cannot render
      Object not found JBossJiraSoapMonitoringPortletInstance

      If I navigate to http://localhost:8080/kosmos-server/ then I see a directrory listing, so it would appear that is happy. The same goes for slide.

      Can someone point out what I am doing wrong?