Hmm using the componentName as default seems to make more sense than attachment.class.name.
I committed a patch to the default managedObject populator to set the hasDefaultName to false, when having a @ManagementObjectID. This was also causing some regressions in our tests. Although i haven't done a new jboss-mean release yet.
|Retrieving data ...|