4 Replies Latest reply: Apr 6, 2008 6:26 AM by Anil Saldhana RSS

svn --non-interactive failing

Scott Stark Master

I'm trying to release the common-logging-spi project using mvn release:prepare, and it keeps failing on the svn. It appears to be a specific issue with running svn with --non-interactive as if I run the same command outside of mvn I see the same error:

valkyrie:trunk starksm$ svn --non-interactive copy --file /tmp/maven-scm-614745047.commit . https://svn.jboss.org/repos/common/common-logging-spi/tags/2.0.5.GA
svn: PROPFIND request failed on '/repos/common/common-logging-spi/tags/2.0.5.GA'
svn: PROPFIND of '/repos/common/common-logging-spi/tags/2.0.5.GA': authorization failed (https://svn.jboss.org)


Runnng the same command without --non-interactive works fine:
valkyrie:trunk starksm$ svn copy --file /tmp/maven-scm-614745047.commit . https://svn.jboss.org/repos/common/common-logging-spi/tags/2.0.5.GA

Committed revision 2795.


Can't remember having this issue before.

  • 1. Re: svn --non-interactive failing
    Scott Stark Master

    I figured it had to be a problem with not picking up the svn credentials, so I explicitly passed those in using the plugin properties, and that allowed it to succeed:

    mvn -Dusername=scott.stark@jboss.org -Dpassword=*secret* release:prepare
    ...
    [INFO] Executing: svn --username scott.stark@jboss.org --password ***** --non-interactive commit --file /tmp/maven-scm-390999263.commit --targets /tmp/maven-scm-16507-targets
    [INFO] Working directory: /Users/svn/Common/common-logging-spi/trunk
    [INFO] Release preparation complete.
    [INFO] ------------------------------------------------------------------------
    [INFO] BUILD SUCCESSFUL
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 18 seconds
    [INFO] Finished at: Sat Apr 05 16:18:33 PDT 2008
    [INFO] Final Memory: 4M/10M
    [INFO]
    


    I guess there is a problem with the svn behavior on this box in non-interactive mode. Since its not prompting for anything when run interactive I don't know where the problem lies.


  • 2. Re: svn --non-interactive failing
    Anil Saldhana Master

    We can answer once you tell us what the *secret* is? ;)

  • 3. Re: svn --non-interactive failing
    Scott Stark Master

    I figured with all the security interops your doing that you would have picked up some hacking methods to figure this out like they do in the movies by now.

  • 4. Re: svn --non-interactive failing
    Anil Saldhana Master

    Passing the pass via the command line is lot better than storing it in clear text in settings.xml (which typically gets passed around in the team to jump start someone's maven usage).