2 Replies Latest reply: May 12, 2009 4:51 AM by Alessio Soldano RSS

Mavenization and snapshot dependencies

Alessio Soldano Master

Hi Jim/Stefano,
I see we currently depend on snapshot versions of the maven-site-plugin and cobertura-maven-plugin. Is there a reason for using the snapshots instead of the latest released versions there? I think it would be better to refer to non-snapshot versions before releasing 1.0.1.
Thanks

  • 1. Re: Mavenization and snapshot dependencies
    Jim Ma Apprentice

     

    "alessio.soldano@jboss.com" wrote:
    Hi Jim/Stefano,
    I see we currently depend on snapshot versions of the maven-site-plugin and cobertura-maven-plugin. Is there a reason for using the snapshots instead of the latest released versions there? I think it would be better to refer to non-snapshot versions before releasing 1.0.1.
    Thanks

    It is because there are some issues in the non-snapshot version. The cobertura release plugin can not inject the probe code in the integration module . It is failed to generate code coverage report.

    The release site plugin also has some issues. I remembered it can not generate the correct index.html and links to the other module correctly . But the site snapshot plugin fixed some of these issues and not all of them .