As I mentioned in the previous blog post (, m2e-wtp had to be pulled out of the m2e marketplace, as it forced its installation for all non-WTP systems.


In order to fix this issue, the code responsible for generating the MANIFEST.MF for all projects had to be integrated into the mavenarchiver feature.

That means m2e-wtp 0.13.1 now requires the installation of mavenarchiver from the m2e-extras update site. It will be discovered automatically from the new m2e-wtp update site, hosted by Red Hat, so it will be completely transparent for new users.

However, please note that the mavenarchiver feature replaces the pomproperties one, so the pomproperties must be uninstalled before upgrading m2e-wtp.


Thus, the preferred ways to install m2e-wtp remain :


1) Import existing Java EE projects into the workspace; You'll be proposed to install the m2e-wtp plugin :


click on Finish and the installation will proceed. Your projects will be imported but the workspace will have to be restarted.


2) Go to Window > Preferences > Maven > Discovery and click on "Open catalog". Select m2e-wtp and proceed with the installation.


3) Old school installation : Use this JBoss / Red Hat update site : 


While reviewing the installation details, you can see that mavenarchiver 0.14.0 will be found and installed automatically (provided there is not a more recent version already installed)



Other that the changes necessary to reinstate m2e-wtp to the m2e marketplace, There is only one other bugfix in 0.13.1, which fixes deployment of war archives overlays in Windows (


UPDATE (03/08/2011) : m2e-wtp is now also available from the Eclipse Marketplace. However, it seems some people are unable to install it directly. Please note that m2e-wtp requires m2e 1.0. So, if it's not installed already, Eclipse must be able to find it in the available update sites.

m2e can be installed from either (for Indigo) or (for Helios and Indigo).

The change in m2e's namespace (org.maven.ide -> org.eclipse.m2e) between m2e 0.12.x and 1.0 renders updates impossible from m2e-wtp 0.12.x to 0.13.x. Thus you have no choice but to uninstall m2e < 1.0 and m2e-wtp < 0.13 before proceeding with m2e-wtp 0.13.x's installation.

(I hope I'm clear enough :-))